The prototyping tool menu

Workspace main menu

menu interface justinmind

  1. Justinmind – commands include references, services and quit. Note that this item is for Mac users only
  2. File – commands related to the handling of Justinmind prototypes (open, save, close, export, import etc.)
  3. Edit – commands related to the handling of information within a Justinmind prototype (copy, paste, undo, redo etc.)
  4. View – commands related to the appearance of the Justinmind workspace
  5. Simulate – commands related to the simulation of a prototype
  6. Widgets – commands related to Justinmind’s Widget libraries
  7. Share – commands that allow you to share your prototype with others via your online account
  8. Teamwork – commands related to team prototyping (add/remove users, show version history etc.)
  9. Plug-ins – commands related to Justinmind’s plug-ins (install a plug-in, configuration settings etc.)
  10. Help – commands related to account and prototyping support (Support, Check for updates, About Justinmind prototype etc.)

Justinmind menu (only for Mac)

justinmind-menu-mac-1

  1. About Justinmind – provides detailed product information (Justinmind version, key and maintenance details can be found here)
  2. Preferences (this is the “File” main menu option for Windows users) – click the “Preferences” main menu option or enter “⌘” + “,” on your Mac keyboard to be taken to a dialog containing a set of preferences. See the “Preferences” section below for details on this dialog.
  3. Services – click to change system preferences in relation to the Justinmind editor (keyboard, language, fonts etc.)
  4. Hide Justinmind – click or enter “⌘” + “H” to minimize Justinmind
  5. Hide other – click or enter “⌥” + “⌘” + “H” to minimize all windows apart from Justinmind
  6. Show all – click to make all windows appear again
  7. Quit Justinmind – click or enter “⌘” + “Q” to close Justinmind

Preferences

From this dialog, you can modify various program-level user preferences. Your changes will remain intact upon re-opening the Justinmind editor. These are the user preferences you can modify:

General – these are the general preferences that apply to all aspects of the Justinmind editor:

    • justinmind mac menu preferences

General Settings

  • Show welcome window on startup – tick to have the welcome window appear upon startup
  • Show overview on startup – tick to have the overview appear upon startup
  • Open prototypes in a new window – tick to have open each prototype in a separate Justinmind editor window
  • Submit statistical information to improve the product – tick to allow error reports to be sent to Justinmind. Activating this option helps us perform product updates and solve performance issues and bug fixes submitted by our customers
  • Display tips – tick to have tips related to features appear on the canvas when working with Justinmind. This option is strongly recommended for new users
  • UI Mode – select a UI mode (Dark, Light or High Contrast – the default is Dark)
  • Default browser – browse your folders and select the default browser with which to simulate your prototypes. Leave blank to use your system’s default settings

Simulate

  • Include comments – tick to include the comments when you simulate your prototype

Export to HTML

  • Optimized – tick to generate HTML prototypes whose source code has been optimized for improved performance (note that this may affect readability)
  • Ask for comments inclusion – tick to confirm whether comments will be included upon exporting your prototype to HTML each time
  • Include Comments – tick to always include comments in HTML exports
  • Override existing files – tick to override the HTML each time you export to HTML

Automatic Updates

  • Check for updates interval (in minutes) – enter the amount of time (in minutes) after which you wish Justinmind to check for updates. The default amount of time is 30 minutes
  • URL for updates – the URL where updates are stored. Change the URL to modify the location of the updates (not advised)
  • Check for updates automatically – tick to allow the system to check for updates automatically after a pre-determined amount of time
  • Check for updates on startup – tick to allow the system to check for updates on startup

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

Backups – these are the preferences related to backup copies of your prototypes. Backups are automatically created in order to prevent data loss:

  • justinmind mac menu backups

Autosave

  • Enable autosave – tick to enable the Justinmind editor to autosave your work after a pre-determined amount of time
  • Autosave interval – enter the amount of time (in minutes) after which you wish Justinmind to autosave your work. The default amount of time is 10 minutes
  • number of backups – enter the maximum number of backups per prototype. The default number is three

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

Functional Scenario – these are the preferences related to the look and feel of functional scenarios. From here you can change the scenario ruler preferences, grid type, etc.:

  • justinmind mac menu functional scenario

Ruler options

  • Show Rulers – tick to show rulers in the Scenarios module
  • Rule units – select a unit from the drop-down (Inches, Centimeters or Pixels – the default is Pixels)

Grid options

  • Show Grid – tick to show grid in the Scenarios module
  • Snap to Grid – tick to snap elements snap to their closest grid line when moving or positioning them within in the Scenarios module
  • Snap to Geometry – tick to snap elements to each other’s boundary lines when dragging them across the canvas in the Scenarios module
  • Grid spacing (in pixels) – enter the amount of grid spacing in pixels. The default is 20 pixels

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

JIRA integration – these are the JIRA integration configuration settings:

  • justinmind mac menu jira integration
  • User name – enter your Atlassian JIRA user name
  • Password – enter your Atlassian JIRA password
  • URL to your JIRA instance – enter the URL of the Atlassian JIRA project you want to associate to Justinmind
  • Project key – enter your Atlassian JIRA project key
  • Import JGL – enter your JIRA JQL here. Find more info on constructing a JQL here.

Learn more about Justinmind’s Atlassian JIRA integration here.

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

Justinmind account – these are the settings related to your Justinmind account and teamwork features:

  • justinmind account

Justinmind account

  • Email – enter the email address associated with your Justinmind user
  • URL – a link to your online account

Teamwork

  • Lock elements automatically – tick to lock elements automatically when working on a shared prototype. Learn more about Justinmind’s Teamwork features here.

Reshare

  • Synchronize comments before resharing – tick to synchronize comments before resharing

Local data

  • Delete all local files under the current user – click the “Clear Data” button to delete all local files for this user

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

Network Configuration – if you’re using a proxy serve to connect to the internet, you can configure your network connection here:

  • network configuration
  • Enable proxy configuration – tick to enable proxy configuration
  • Host – enter your proxy’s host
  • Port – enter your proxy’s port
  • User – enter your proxy user
  • Password – enter your proxy
  • Protocol – select a protocol from the drop-down (HTTP/HTTPS or SOCKS – the default is HTTP/HTTP)

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

Requirements – these preferences relate to your Requirements fields:

  • Select the fields you want to display in the Requirements module (Author, Type, Comments etc.)
  • menu requirements

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

TFS integration – these are the Microsoft TFS integration configuration settings:

  • tfs integration
  • User name – enter your Microsoft TFS user name
  • Password – enter your Microsoft TFS password
  • URL to your TFS instance – enter the URL of your Visual Studio work space
  • Project key – enter the abbreviated name of the TFS project

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

User Interface – these preferences relate to the visual aspects of the Justinmind editor. They concern the behavior of all screen UI elements, as well as the canvas in the Screens, Templates and Masters palettes:

  • user interface menu

Ruler options

  • Show rulers – tick to display rulers at the top and left of the canvas
  • Ruler units – select a unit from the drop-down (Inches, Centimeters or Pixels – the default is Pixels)

Grid options

  • Show resolution guides – tick to display the resolution you are currently working within
  • Show Grid – tick to show grid
  • Snap to Grid – tick to snap elements snap to their closest grid line when moving or positioning them within
  • Snap to Geometry – tick to snap elements to each other’s boundary lines when dragging them across the canvas
  • Show Smart Guide – tick to show smart guides
  • Grid spacing (in pixels) – enter the amount of grid spacing in pixels. The default is 20 pixels

Default Content Alignment

  • Centered – tick to center the content on-screen. This will only take effect in simulation mode, not while editing in the canvas

Images

  • Show include/link image option when adding images – tick to make the “Link to image file” when adding an image

Events

  • Create new events with progressive disclosure – tick to show the options in the Events dialog one at a time (ticked by default in Beginner Mode)

Click “Apply” to save your changes or “Restore Defaults” to restore default factory settings.

File menu

From the “File” main menu option, you can perform operations related to the handling of Justinmind files that help the user perform specific tasks.

file-menu-1

  1. New – click to quickly create new prototype components. Hover over this option to open a sub-menu with the following items:
    • Prototype – click to create a new prototype and open it on the canvas
    • Shared prototype – click to create a new prototype, open it on the canvas and share it with other users. Learn more about shared prototypes here
    • Screen – click to create a new screen in the current prototype
    • Data master – click to create a new Data Master in the current prototype
    • Template – click to create a new template
    • Scenario – click to create a new scenario and open it in the Scenarios module
  2. Open – click or enter “⌘” or “Ctrl” + “O” to open an existing prototype. From the Open dialog that appears, select a Justinmind.vp file and then click “Open”
    • The current prototype will be closed. If you want to open more than one prototype at a time, you can either launch two prototypes or double-click on each of the .vp files.
  3. Open shared prototype – click to open a shared prototype. From the Open dialog that appears, select a Justinmind .vp file and then click “Open”
    • The current prototype will be closed. If you have no internet connection you will be requested to work offline.
  4. Recently Opened Prototypes – click to view a list of recently opened prototypes and select one to open in the canvas
  5. Close – click or enter “⌘” or “Ctrl” + “W” to close the current prototype
  6. Save – click or enter “⌘” or “Ctrl” + “S” to save changes to the current prototype
  7. Save as – click or enter “⌘” or “Ctrl” + “Shift” + “S” to save as (brings up a prompt to save your prototype as a file with a different name, you can also choose where to save your prototype)
  8. Export to Document – click to automatically generate specification documents from the current prototype. Choose from the two options in the contextual menu:
    • Export to DOCX -generate a .DOCX specification document of the current prototype
    • Customized Document – open the Customized Document dialog to customize the contents of your specification document
  9. Export to HTML – click or enter “Shift” + “⌘” + “T” or “F7” to export your prototype to HTML
  10. Save as images – click or enter “Shift” + “⌘” + “I” or “F8” to save a prototype’s screen as an image file (the screen currently displayed on the canvas)
  11. Recover prototype – click to recover a backed up prototype
    • For Windows only:
    • Preferences – see “Preferences” above
  12. Import – click to import prototype components from other prototypes into the current prototype. Choose from the following options: Prototype, Screen, Template, Master, Widget Library or Data Master from .csv file
  13. Export – click to export components of the current prototype. Choose from the following options: Prototype, Screen, Template, Master or Comments.
  14. Requirements configuration – click to configure Requirements Fields
  15. Import .sketch file – click to learn how to import a Sketch artboard into Justinmind

For Windows only:

Exit – click to close Justinmind. You will be promote to save any open prototypes.

Edit menu

From the “Edit” main menu option, you can perform operations relatd to the handling of information within a Justinmind prototype.

edit-menu-1

  1. Undo – click or enter “⌘” or “Ctrl” + “Z” to undo the last modification and revert back to the previous state
  2. Redo – click or enter “⌘” or “Ctrl” + “Y” to redo the last undone modification
  3. Copy – click or enter “Shift” + “⌘” or “Ctrl” + “C” to copy the current selection to the clipboard
  4. Cut – click or enter “Shift” + “⌘” or “Ctrl” + “X” to remove the current selection from the canvas and place it on the clipboard
  5. Paste – click or enter “Shift” + “⌘” or “Ctrl” + “V” to paste the contents of the clipboard onto the canvas
  6. Delete – click or enter “Delete” to delete the selected items
  7. Select All – click or enter “⌘” or “Ctrl” + “A” to select all the items on the canvas
  8. Duplicate – click or enter “⌘” or “Ctrl” + “D” to duplicate the selected item
  9. Find – click or enter “⌘” or “Ctrl” + “F” to open a search dialog and look for text terms within UI elements in your prototype’s screens
  10. Replace – click or enter “⌘” or “Ctrl” + “R” to replace a text entry in your prototype with another text entry
  11. Order – click to reposition UI element hierarchy on the canvas. Choose from the following options:
    • Bring to front – brings element to the front of the stack
    • Send to back – brings element to the back of the stack
    • Move forwards – moves element forward by one level
    • Move Backwards – moves element backward by one level
  12. Align – click to re-align the selected UI elements. To use the align options, select two or more UI elements on the canvas. Choose from the following options:
    • Align left – align element(s) to left of the last-selected element
    • Align center – align element(s) to center of the last-selected element
    • Align right – align element(s) to right of the last-selected element
    • Align top – align element(s) to top of the last-selected element
    • Align middle – align element(s) to middle of the last-selected element
    • Align bottom – align element(s) to bottom of the last-selected element
    • Distribute vertically – distribute elements vertically
    • Distribute horizontally – distribute elements horizontally
    • Match width – match width of last-selected element
    • Match height – match height of last-selected element
    • Match size – match size of last-selected element
  13. Group – click to group UI elements together, or in a Dynamic Panel or Master
  14. Center content – click to center content on the canvas
  15. Save as image – click to save the selected items as an image (a screenshot). If no element is selected, the blank canvas will be saved

View menu

From the “View” main menu option, you can perform operations related to the appearance of the Justinmind workspace.

The View commands differ depending on the Module you’re in.

View menu

  1. Zoom In  – click to zoom in on the canvas
  2. Zoom Out – click to zoom out of the canvas
  3. Zoom 100% – click to zoom to a 100% view of the canvas
  4. Zoom to Fit All – click to zoom to fit to the canvas
  5. Rulers – click to show/hide rulers on the canvas
  6. Grid – click to show/hide the grid on the canvas
  7. Snap to Grid – click to activate/deactivate automatic alignment
  8. Snap to Geometry – click to activate/deactivate the automatic alignment system
  9. Smart Guides – click to activate/deactivate smart guides on the canvas
  10. Fade template components – click to fade/unfade template components on the canvas
  11. Mask Panels, Master and Hotspots – click to show/hide the overlay that indicates a Panel, Master, or Hotspot
  12. Components marked as hidden – click to show/hide components marked as hidden on the canvas during editing
  13. Markers – select which markers you want to see on the canvas (events, pinned positions, comments, and requirements)
  14. Palettes – click to show/hide each palette
  15. Beginner/Expert Mode – click to switch the Justinmind editor to beginner or expert mode
  16. Reset workspace – click to reset default workspace settings

Simulate menu

From the “Simulate” main menu option, you can perform operations related to the simulation of a prototype.

simulate-menu-1

  1. Simulate Prototype – click to launch a Chromium-based simulation of with the screen or template you currently have open in the Justinmind editor
  2. View on smartphone/tablet – click to publish your prototype to your account and view it with a real mobile device using the Justinmind mobile application.
  3. Simulation settings – click to configure how your prototype will be displayed either in simulation, once exported to HTML, or when you publish it to your online account
  4. Preview screen – click to preview of the current screen. In this preview the events won’t work

Widgets menu

From the “Widgets” main menu option, you can perform operations related to Justinmind’s Widget libraries.

widgets-menu-1

  1. Add/Remove libraries – click to add or remove pre-installed libraries to the Widget library palette
  2. Download Libraries – click to be taken to the UI Libraries page on Justinmind’s website, where you can download and install additional widget libraries to use in your prototypes
  3. New Widget Library – click to create your own widget library.
  4. Commit all shared libraries – click to save changes to a shared widget library
  5. Update all shared libraries – click to receive all updates for a shared widget library

Learn more about Widget libraries here.

Share menu

From the “Share” main menu option, you can perform operations that allow you to share your prototype with others via your online account

share-menu-1

  1. Share – click to share a prototype to your online account and invite collaborators to review it
  2. Reshare – click to update a shared prototype with recent changes
  3. Replace published version – click to replace a published prototype with a new version (similar to “Save As”)
  4. Manage published prototypes – click to manage all your shared prototype in your online account
  5. Refresh comments – click to refresh comments on your shared prototype
  6. Settings – click to configure simulation settings

Learn more about working with shared prototypes here.

Teamwork menu

From the “Teamwork” main menu option, you can perform operations related to team prototyping.

teamwork-menu-1

  1. Open shared prototype – click to open a shared prototype
  2. Share prototype – click to share a prototype to your online account
  3. Manage shared prototypes – click to manage all your shared prototype in your online account
  4. Add/Remove users – manage which Justinmind users have access to your shared prototypes
  5. View locked elements – click to view which UI elements and screens have been locked
  6. Commit all – click to save all changes you have made to the shared prototype you’re currently working on
  7. Update all – click to receive updates to your shared prototype made by all users
  8. Discard all changes – click to discard changes to your shared prototype made by all users
  9. Unlock all – click to unlock all UI elements and screens
  10. Show history – click to show all changes in a version history
  11. Close prototype – click to close the shared prototype you’re currently working on

Learn more about using our Teamwork features here.

Plug-ins menu

From the “Plug-ins” main menu option, you can perform operations related to your Justinmind plug-ins.

plug-ins-menu-1

  1. Install a plug-in – click to install a plug-in. Learn more about available plug-ins and integrations here.
  2. Code your own plug-in – click to code your own plug-in
  3. JIRA – click to install the Justinmind for JIRA plug-in
  4. Team Foundation Server – click to install the Microsoft Word Team Foundation Server plug-in

Help menu

From the “Help” main menu option, you can perform operations related to account and prototyping support.

help-menu-1

  1. Show Welcome Window – click to view the Welcome dialog that you see upon first opening Justinmind. From here you can create a new prototype or open an existing one.
  2. Show Overview – click to view the Overview dialog, with a wizard to help you get started with Justinmind
  3. Tutorials – click to be taken to Justinmind’s support section
  4. Help Contents – click to View the Help section of Justinmind’s editor
  5. Check for Updates – click to check for updates to your Justinmind editor
  6. Validate account – click to validate your Justinmind key (for new users)
  7. About Justinmind Prototyper – click for detailed product information (Justinmind version, key and maintenance details can be found here)
  8. Visit Justinmind’s Homepage – click to be taken to the Justinmind website Homepage 9) Sign out – click to sign out of the Justinmind editor