Oh so buggy...

ERTurner shared this problem 22 months ago
In Progress

I'm a bit confused. I just started using the free Enterprise trial for this tool, and at first it looked like a great product. But as I've been using it for the last couple of days, I keep running into bug after bug... and Google search results haven't turned up any reasonable solutions. In fact, the response I seem to see most is "is it really that bad to deal with?". Yes. Yes it is; it's death by 1000 cuts.

Note: I'm running Windows 10 (up to date), and have saved, closed, and restarted my computer many times without any of the below changing in behavior. I also checked for updates for Justinmind.


Here's what I've found so far:

  • Simulate doesn't update. I keep adding new components to the screen, and simulate always stays the same.
  • Shadows don't appear in prototyping. This is so horribly annoying when I have overlapping elements that are the same color except for a shadow.
  • Objects don't snap to other objects. I have the view option for "snap to geometry" turned on, and this was working for the first day I was using this program, but now it has stopped working. Really annoying when trying to align stuff.
  • Tools don't have any kind of hover label. I find it odd that a UX program could use a little UX itself. I keep trying to hover over different tools to see what they do, but there aren't any identifying labels. I just have to guess.
  • Font sizes are weird. I can't tell if font size is in px or pt, but either way the font seems larger than it should. I have seen some posts about font sizes differing between prototyping mode and simulation, but I can't get my simulation to work to even see if this is why the font size seems off.
  • Can't group layers if they're already in a group. I have to move the layers outside of their group, group them, and then add them back. What a pain.
  • There are probably more things I've just forgotten to note down...


Don't take me wrong, I really want this tool to be good. I could really use it, but I'm really surprised how many issues there are... is this just me?

Comments (6)

photo
1

Hi there,


1) Simulation only updates when you press 'simulate' in Justinmind, and it will open a new simulation tab.

2) You're right that shadows don't appear in the application canvas - I'll forward that idea to our development team.

3) I haven't been able to reproduce this - is there something in particular that seems to cause the snap to stop working? Does it still not work after restarting Justinmind?

4) Which tools are you referring to? We have tooltips for most of the elements in the user interface.

5) Font size is in pt - you can use this resource here to convert your pt to px (http://reeddesign.co.uk/test/points-pixels.html)

6) You're right that you can't group items once they're in a group - I'll also forward that idea to our development team.


Please feel free to send along any other bugs you've encountered, we greatly appreciate your feedback.


Best,

Danielle

photo
1

I really appreciate the quick response. Like I said, I really want this tool to work for me.


1) I have been clicking the Simulation button and opening the new window. It hasn't been updating with any of the changes I made on the prototype. (see attachment Capture1) I've tried saving and restarting with no luck.


3) I just restarted the program. To be more specific about the snapping, some snapping does seem to work, but other times it doesn't. I have a long rectangle at the top of the canvas that is a navbar, and I have a group of elements making up a sidebar link in a sidebar rectangle. The sidebar link group snaps to the navbar, but it doesn't snap to another sidenav link group. Maybe because they're both groups? Attachment Capture2 shows the items that are not snapping to each other. I'm specifically trying to stack them vertically, snapped to each other, and it isn't working. I was also having trouble vertically aligning the icon within the rectangle that makes up the sidenav link.


4) While hovering around to answer this question, I realized my mistake. Justinmind does have hover labels on tools. It looks like the hover labels are disabled on tools that are disabled. That's what was throwing me off. I actually think this should still be fixed. If an option is disabled, I want to know what it is so I can figure out why it's disabled. I still don't actually know what some of these disabled tools are. Also, I noticed that some of the coloring tools have a hover to show what the color is, which is really nice, but there isn't a label on the icon before the color, so it isn't always clear what the color is for. What is pencil color vs teardrop color? They're disabled at the moment, so I'm not sure what element I might use to test them and see what they are. See attachment Capture3.gif


5) Okay, being in pt is probably why the size is off. I'm curious why pt and not px? Justinmind is definitely not the only program that uses pt over px, so I must be missing something, but css usually uses px in web design so I'd think that would be more useful for this use case. Again I'm probably missing something here.


Thanks again for the fast response. I'm obviously an opinionated person (and rather blunt), but I don't bother sending feedback for apps I don't think are worth it.

photo
1

1) That's very odd - could you attach the prototype you're working on here so we can take a look? You can attach it in .rar format, or upload it to a file sharing service like Dropbox and link to it here. If it's a private prototype, you can send it to jim.support@justinmind.com

2) Vertical snapping is working quite well for me, even with groups. Hopefully I will be able to see what you mean in the prototype you attach.

3) Thanks for clarifying. I'll let our development team know that this can be confusing. The pencil color is the border color, while the teardrop is the background color.

4) I'm actually not sure why we use pt instead of px - I'll ask our development team and let you know. I'll also let them know that users would like to use px instead.

photo
1

I've emailed in the original file to the support email. I appreciate your quick replies and willingness to help!

photo
photo
1

To add to this, the application did look ideal based on everything I had seen and read prior to installing but after using it I find the system performance to be slow. I've attached my system specs as an image file. I don't suspect that to be the issue. Specifically moving items around the interface is slow and, like earlier, the snapping system is inconsistent. Also, the properties panel is painfully slow as well, i.e. clicking on the up and down arrows to adjust values.


Another issue is that creating rounded corners. It is slightly unintuitive to have it as a property of the border. I realize this is how CSS works but it really should be a property of the shape itself, or at the very least make it work when I set the border to 'none'. Currently, you have to set the border style and then set the thickness to 0 in order to maintain the border radius (as far as I can tell anyway).


I also added this topic as well a little while ago: https://www.justinmind.com/community/topic/master-button-not-showing-up-in-data-grid


Lastly, it would be great if you gave the option to wire events up by writing code. The current system is ok but clunky. Plus, improving the documentation for each function would help.


Anyway, I really want to like your software because of the dynamic data-driven nature of it but I'm currently finding it very hard to do.

photo
1

You can try increasing the amount of memory Justinmind is able to use, which will better performance. To do this, command-click on the Justinmind application in your applications menu and select 'show package contents'. Then, open the folder 'contents'. There, open the file Justinmind.ini and change the parameter Xmx from 1024m to 2000m.

Let me know how that works for you.


I've seen your data grid question and asked a quick clarifying question.


Unfortunately we don't have any plans to integrate code into Justinmind as it would be a very big change, but I'll let our development team know that more documentation is needed.

photo