Unable to export Jira requirements to alternate project

Cameron Gull shared this problem 29 days ago
In Progress

I previously Exported all requirements to Jira; however, it was to the wrong project. I need to export them to the correct project, but after changing the configuration and choosing "Export Requirements", nothing happens - the "Export Requirements" progress window appears for a split second and then disappears. In short, nothing happened.

How can I reset the "Integration tool URL" so I can do a fresh export to a new Jira project?

Comments (10)

photo
1

Go to Preferences -> Jira integration -> Restore defaults.

photo
1

Thank you Danielle for the reply; however, that's not actually the issue.

The issue is that once you have exported requirements, each requirement is linked to a specific URL in Jira (contained in the "Integration tool URL" field in the Requirements window). Even if you were to change those preferences, upon Export, it still writes to the existing URL.

For example when looking at a requirement:

Code: ABC-123

Version: 1.0

Name: Save the planet

...

Integration tool URL: https://jira.blabla.gov/browse/ABC-123

Even though in the configuration I specify a different Project Key of "XYZ", it still writes to the original one of "ABC".


Any suggestions?

photo
1

Danielle, any tips? I've got to get this resolved today. Thank you for your help!

photo
1

Apologies for the delay - we ran into an issue with Jira while looking for a solution because they changed their API functionality.

photo
1

Here's what you should do:

  1. Export your requirements to a CSV
  2. Open that CSV file and remove the column 'Code'
  3. Delete the requirements in your prototype
  4. Import the requirements from the CSV file. That will get all the requirements without linking to the old project
  5. Finally, if you set the destination project in the Configuration of the JIRA plugin and execute the 'Export', you will be able to add those requirements to the new JIRA project.

photo
1

Thank you, Danielle!

I've followed your instructions. After importing, "Code" now shows 1, 2, 3, 4, etc. as expected; however, when trying to export to Jira, nothing happens – meaning, the export modal appears for a split second and goes away and I'm not seeing the expected behavior of actually exporting them individually and it showing up with a new "Code" and "Integration tool URL".

As a test, I was set as "Administrator" of the Jira project, so it's not permissions.

Thoughts?

photo
1

Can you attach your log files after the export? You can find them by following this file path:


On PC: C://users/youruser/Justinmind[version]/logs.log

On Mac: [folder of the user]/justinmind/version/logs.log

You'll need to compress them into .zip/.rar format to attach them here.

photo
1

I just noticed the following (before I saw your response):

[ModalContext ] [2019-04-25 13:46:44] DEBUG com.justinmind.prototyper - JIRA connect to: https://jira.inl.gov/rest/api/2/issue/1/editmeta Status: 404 Message: Response: {"errorMessages":["Issue Does Not Exist"],"errors":{}}[ModalContext ] [2019-04-25 13:46:44] DEBUG com.justinmind.prototyper - JIRA connect to: https://jira.inl.gov/rest/api/2/issue/ Status: 400 Message: Response: {"errorMessages":[],"errors":{"components":"Component/s is required."}}


We have a required field called "Component". Any way to configure that in Justinmind?

photo
1

BTW: we turned off the "Required" setting for "Component" and I was able to import them all. Yay!

However, is there a way to specify the component within Justinmind so I don't have to do this each time I export (certainly not ideal)?

photo
1

Not right now, but we'll take that into account for future updates of the plugin.

photo