Trouble with screensize, resolution, ppi etc

Floris van der Meijs shared this problem 9 months ago
Known

Hi,

I have to make a design which is to be shown on a 12,1 inch, 1680x1050 screen and I’m having trouble with choosing the correct settings for the prototype.

If I take the resolution of the target screen of 1680x1050 I get a screen which is much larger, probably due to a different ppi. I've searched for a possibility to change the ppi setting in Justinmind but have not been able to find it.

Then I tried a different approach and selected a resolution which results in a screen that has the dimensions of the target screen (10,3x6,4inch). This meant I had to set a resolution of 990x616.

When I then run a simulation set at 100% I get a screen that does not have the dimensions as the canvas has, its smaller.


I do not have the physical target screen available yet so I cannot test it on the actual target yet.


Because all the requirement I’ve got concerning sizes of icons, touch surfaces etc are in mm I’d like to work with mm guides. Therefore the actual size of the screens in the prorotype is very important for me. Furthermore I would like to be able to simulate in actual size in order to validate the requirements I got.


Could you please advise me on what the proper settings are for achieving my goals.


Thanks in advance.

Comments (5)

photo
1

Hi there,


Are you using a High DPI display?


Best,

photo
1

Hi Sonia,

Do you mean the display of the target device? This is a 12,1 inch, 1680x1050 and if i'm not mistaken this implies a DPI of 164.

regards

photo
1

Dear Floris,

Look for and launch this file and it should fix the issue:

C:\Program Files (x86)\Justinmind\Justinmind Prototyper 8.2.0\JustinmindPrototyperHiDPI.exe


Best,

Sonia Durán

photo
1

Hi Sonia, i followed your advice but run in to the same problems.

I do not have the 8.2 version though, I have the 8.1.

regards

photo
1

Dear Floris,

You should set the final resolution of the prototype when creating a new project. Also at the simulation settings gear (next to the simulate button) select the "fit to screen" option.


Best,

Sonia Durán