The "Gear" icons that show interactivity need a "Show/Hide" control.

James Brooks shared this problem 1 year ago
Not a Problem

I can appreciate that some folks need to see the "Gear" icons to see where they have interactivity applied to elements. However, that function really needs a way to Show/Hide those elements. They are starting to clutter up and take over the UI in the Editor. Even when the items are turned to visibility-off in the Outline panel the little gear icons still display. This feels like a bug. If I turn off the elements the gear icons should also be hidden.


Please see my attached screen. This is not optimal.

Comments (4)

photo
2

Hi James,


You can toggle the visibility of event markers by going to View -> Markers -> Uncheck event marker. This should help declutter your workspace.


Hope this helps.


Best,

Danielle

photo
2

Excellent.


I should've looked harder for that. But thanks for letting me know where it is.

photo
1

Now I am having the same problem with the Hidden Object indicator icons. I want to leave the hidden items themselves visible or not depending on the visibility icon in the outline panel (also an eyeball) but I don't need a whole bunch of additional eyeball icons floating around everywhere on the page. They are confusing the interface. I know which things are supposed to be hidden or not without any indicators.

photo
1

Dear James,

Unfortunately, those eyeball icons can't be hidden, however, I will transfer your suggestion to our development team so they can take it into account this feature for future updates.

Sorry for any inconvenience.


Sonia Durán