Prototype is up to date but cannot be commited because not up to date.

Jon.S shared this problem 2 years ago
Solved

Hello,


I'm facing a bug in the application with the teamwork functionality. Here is my issue :


When I try to commit my prototype with the function "Teamwork - Commit all" I get the error message : "You don't have the last revision of the current prototype. Please update the prototype first".


So I try to update the prototype by using the function "Teamwork - update all", and then I get the message "The prototype is already up to date".


So it looks like I am in a dead end: I cannot commit my prototype because it's not up to date but I cannot update my prototype because it's already up to date. On top of all of this, I cannot close the application because I have changes in my prototype which are not committed. So I'm force to kill the application with CTRL-ALT-DEL. This is really annoying.


Any idea how to solve this issue ?

Comments (6)

photo
1

Hi Jon,


Sorry about that! Are you the owner of the prototype? If not, try deleting the prototype from your computer, and then re-downloading the shared prototype. This should hopefully fix the issue and allow you to start making changes to the latest version of the prototype again.


Please let me know how this works for you.


Best,

Danielle

photo
1

Hi Dani,


Actually I am owner of the prototype. Where would I find the local copy which should be deleted ? (I'm on windows)

photo
1

Hi Jon,


Since you are the owner of the prototype, it's a little more complicated to resolve. We're looking into this, and I will get back to you ASAP.


Best,

Danielle

photo
1

Hi Jon,


First, save a local .vp file with your current work using the option File -> Save a copy.


Then, go to Preferences -> Justinmind Account -> Clear data.


Now, you can go to Shared prototypes -> Open shared prototypes, and you'll download the teamwork prototype again.


You can now copy/paste the changes from your old local copy onto the shared copy.


Please let me know how this works for you.


Best,

Danielle

photo
1

Hi Dani,


Yes it solved the issue ! Thanks for your support !

photo
1

Hi Jon,


Very happy to hear that! Feel free to contact us again if this issue occurs once more, or if you have any other questions or concerns.


Best,

Danielle