Manage Widget Library Frozen

Mor Vimmer shared this problem 14 months ago
Solved

I open the manage widget library and imported 3 libraries I downloaded from JIM website. After I added those libraries the "Manage Widget Library" froze and I could not get back to work on the prototype.

Comments (15)

photo
1

This is likely a memory issue. We can try increasing the amount of memory that Justinmind can use. To do this, search for a file called Justinmind.ini in your files. Then, open that file in a text editor. Look for something called Xmx512 and change it to -Xmx1024m, save the file, and open Justinmind again. I hope this helps.

photo
1

Thanks for your help. I opened the file and it was already 1024.

photo
1

If you're using a Mac, you can try changing it to 2000m.

photo
1

Changed it to 2000 and still having an issue. This is really frustrating. I recommended JIM to my team and we are about to purchase it but if it cannot do the basic things, such as importing icons (font awesome library) it is very limited, and not sure if there is a point of using it.

photo
1

If that's the case, there must be another issue. Can you attach your log files in .zip format? You can find them by following this file path:

On Mac: [folder of the user]/justinmind/version/logs.log]

photo
1

Sure. Here you go:

Files: logs.log
photo
1

We've been looking at the logs and unfortunately haven't been able to identify the issue.

Is there any feedback (i.e. loading symbol) when you try to import the libraries? Also, which libraries were you trying to import? This will help us test the problem.

photo
1

Font Awesome, Foundation.

Our trial period is over so now when I just open the widget window I cannot cancel out of it.

I am holding off purchasing the software until this is resolved.

photo
1

Thank you for the info - we'll test that.

I've also extended your trial by 2 weeks while we work to resolve this.

photo
1

Thanks! I appreciate your help on that issue.

photo
1

We have tested loading those libraries and it works ok. While there's no feedback to show library is loading, it actually is - so we recommend to wait just a little more. If after 10~ minutes it never loads, let us know, and if possible try loading those libraries in Justinmind on another computer, and let us know how that works.

photo
1

Funny thing - at any point of this saga libraries were loading fine. At any point when I loaded libraries, I saw the libraries I selected listed on the widget panel. It was when I tried to close the "Load Widgets" window I experienced the issue. There is no "Close/done/etc." button (as in the "new screen" window), so I tried by clicking outside of that window. This did not work. And that is why I thought it was frozen.

It is only now I have noticed the "X" button on the top/right of that window. And that worked.

Sorry for missing this. And thanks for quick response and help!

photo
1

Glad that's figured out!

photo
1

I had the same issue - the "x" on the top right (dark mode/mac) is white until you hover over it. Very confusing, I almost lost a bunch of edits because I hadn't saved before clicking on the manage widget library function.

photo
1

Thanks for your feedback - and apologies for any inconvenience. We'll keep this in mind for future updates to this dialog/process so we can make it more clear.

photo