How Do You Get Hotspots to Work Inside of Layers?

Anthony Brown shared this question 1 year ago
Answered

This seems simple, but it is impossible for me to figure out. In my prototype I have an element that you can swipe and move to the left to reveal an element/layer underneath that has buttons on it. These buttons have hotspots on them that perform Events when clicked. My issue is that the hotspot Events ONLY work when they are on top of every other object in my project. When I place layers/elements on top of my hotspots (even elements that can be swiped away to reveal the hotspots), my hotspots do not work.


I have also tried clicking directly on my images and giving those an Event, but that doesn't work either. Hotspots seem like the only way to make Events using images work, but then the hotspots have to be on top of my entire project in order to work.


Is there any kind of solution to this? I have been going around in circles for hours with no solution found yet.


Thanks.

Comments (3)

photo
1

Dear Anthony,


In order to provide you the best solution , can you send us an example vp.file) applied to the context of the prototype you are working in. You can attach your vp file here in a .rar extension.


Best,


Sonia Durán

photo
1

Hi Sonia,


I actually just figured it out. It appears I must HIDE my layer that was swiped off-screen in order for this to work. When I simply swipe to move the element off-screen it seems as-if the layer is still being treated like it's still there. Swiping to the left and then hiding the layer afterwards seems to fix the issue. The hotspots are still a bit spotty sometimes when scrolling, but it is working much more as intended now.


Not sure if this is a bug or an intended action?

photo
1

Dear Anthony,


It seems a bug. I will transfer this information to our development team so they can take into account for future updates. Sorry for any inconvenience and thank you for taking the time to report this.


Best,


Sonia Durán

photo