Cannot copy or paste in "New Requirement" form fields

Dave shared this problem 4 years ago
Solved

First of all, please delete my prior post, "Cannot paste into 'New Requirement' form fields", as this post replaces it. Apparently, it's impossible to (a) edit a post after a certain period of time or (b) delete your own darn post on Justinmind's Community.


I don't understand why users are prevented from copying from or pasting into the "New Requirements" form (and possibly others) in Justinmind. Sometimes, requirements come via email, instant message, etc: Please allow us to copy and paste into these fields.


Incidentally, here's a workaround for *just* the paste problem. It doesn't help at all with copying. Really, folks, it's not 1980, it's 2014. These problems were solved a generation ago.


1) Be a Mac user


2) Buy and install "Keyboard Maestro"


3) Create a macro that performs the "Insert Text" action


4) Choose "Insert text by typing"


5) Choose "Insert Token > Current Clipboard"


6) Give the macro a reasonable name ( I went with "Overcome Paste Prevention") and hot key trigger (I went with Option-Command-V)


7) Vote for this bug so that Justinmind removes this pitiful restriction, please.

Comments (2)

photo
1

This is one of a number of basic functionality requests I made over a year ago with zero response from JustinMind. You've gotten a LOT more responsive since then, but I bet the current group of excellent customer support folks never saw this request.


If this is still an issue (I don't use Requirements, and it's 7PM on a Friday night, so I'm not launching JustinMind to see if it's a problem elsewhere in the product), please consider making it possible to cut and paste absolutely everywhere that text can be entered.

photo
1

Hi Dave,


Thank you for reporting this. I've been testing it and it is working just with shortcuts. I have transfered this information to our development team in order to fix this bug.


Best,


Sonia Durán