Adding a video from my computer via Document only brings up a download notification

Matthew shared this problem 31 days ago
In Progress

I'm having trouble adding videos to my prototype. As i understand it, to add videos from my computer I first use the Document Special component, and then select the video file under "file" in the properties tab. However strangely every time I attempt to upload a video, instead of displaying the video in the document box, a notification pops up asking if I want to download or save the video file? .

Best Answer
photo

After looking at this further, here's what you should do:

Use an mp4 file in the document widget. You'll see a dialog appear to download or save the video, but just click 'cancel'. When you simulate, the video should appear correctly.

Comments (9)

photo
1

You'll need to convert the video to another format - m4v should work.

photo
1

It appears to do the same with m4v files.

photo
2

Thanks for the info - it looks like it might be different for Windows. I'll ask our team which format should work best on Windows and get back to you soon.

photo
1

Any update?

photo
1

Yes - so on Windows you can instead try two things:

A. Embed the video in an HTML file that you can then put into Justinmind using the HTML widget.

or

B. Upload the video to Youtube or Vimeo, use those sites 'embed' code, and use the HTML widget to embed it in the prototype.

photo
1

This solution is not very convenient. @Danielle: can you please confirm you will fix this bug ? I am facing the same issue.

photo
photo
1

After looking at this further, here's what you should do:

Use an mp4 file in the document widget. You'll see a dialog appear to download or save the video, but just click 'cancel'. When you simulate, the video should appear correctly.

photo
1

This is correct the simulation works well.

However there is another issue. In the editor, each time I navigate on the page containing the video, I am prompted with the dialog box asking me if I want to download it. I can click on "Cancel" as many time as I want, I am asked again and again if I want to download the file.

Very annoying, especially when the video is embedded in a master present in every page of my prototype !

photo
1

Yeah, we realize this isn't ideal. Here's another workaround that's pretty simple you can try. It shouldn't show any dialogs:

1. Drag an HTML widget onto the Canvas.

2. In the Properties palette where it lists the html, paste the following, replacing the location of the file with your video's path, and the videoname with your video's title. Note that this will only work for your local simulation - the video won't work if the prototype is shared to your online account.

<!DOCTYPE html>
<html>
<head>
  <title>video</title>
</head>
<body>
<video width="100%" height="100%" controls>
	<source src="videolocation/videoname.mp4" type=video/mp4>
</video>
</body>
</html>
</html>

photo