Upvote 1

Added Custom Fields for Requirements not showing

In Progress Cameron Gull 5 years ago

To follow the User Story format, I wanted to add custom fields to Requirements in Preferences > Requirements > [Edit Custom Fields]. I'm expecting them to show up when I add a requirement to some object, but it looks exactly the same as before.

In fact, I just now turned off ALL the requirements fields, and the requirements modal hasn't changed at all.

I've even restarted the app a few times.

Mac OS 10.13.6

JIM 8.7.0

Replies (2)

Apologies for any confusion. Editing the requirements fields in Justinmind preferences (your first screenshot) only affects new prototypes, not the one you're currently working on. To edit your current prototype's requirement fields, go to File -> Requirements configuration and change the fields there.


Thank you!

Some additional issues:

1. Export to DOCX doesn't include the custom fields, only the originals. Sadly, that makes custom fields almost pointless (if you're planning to create a DOC).

2. Looking at the "Requirements" section at the bottom of the screen, when I have all the fields disabled except my custom ones, the creation Date shows in my first custom field instead of the data I entered. After playing around with it, it seems that the date always shows in the first custom field regardless of the data that's entered.


We see the limitations you're describing. I'll let our team know that this could be improved.

Leave a Comment
Attach a file