Add image to screen background

Michael Magoon shared this problem 7 years ago
Solved

I am trying to import a screen capture so that it becomes the background of a screen doing the following:


1. Click "Add Image" on the Screen properties palette.


2. Navigate to image.


3. Click Open.


Nothing happens. I have tried this with many image with same result. I am using Mac.

Comments (12)

photo
1

Would you mind to attach a screenshot? You also can drag the image file into prototyper and send it to back.

photo
1

Unfortunately, the screen capture software that I am using (Grab) only creates TIFF images, which cannot be uploaded onto your system.


There really isn't much to see anyway. The interface does not change. The "Add Image" link is still there.


It may be a completely unrelated problem, but when I tried to upload a GIF image into an Image widget, it displays at about 10% regular size. I created the image in Fireworks and it displays at 100% in other apps.

photo
1

Two things:


You say the Add image link is still there after selecting the image file you want to add to the screen. I am right? Well, that's weird.... which is the extension of the image? Does it work in the image widget?


The image widget re-size the image to the size it has but you can restore the original size of the image by pressing the first option next to 'File' in the image widget properties.

photo
1

Yes, it is weird. The screen kind of flickers like something happened, but then it just goes back to its original state.


I am trying to import a TIFF. I have also had problems with GIF. I am able to import within the Image widget, but it has the resizing problem that I mentioned before.


When I click the "Original Image Size" icon, the graphic now displays correctly, but the widget is now huge. When I attempt to resize the widget, it resizes the images as well. This feels like a bug. At the very least, "Original Image Size" should be the default and resizing the widget should not affect the image.

photo
1

I don't fully understand what you mean by 'When I attempt to resize the widget, it resizes the images as well', is not what you want to? If you want to crop it then you have to use the tool in the toolbar next to the 'eraser' tool.

photo
1

Sorry, maybe I was unclear. This is what I did:


1. Created 100 x 100 pixel image widget.


2. Click "Add Image" link.


3. Navigated to image (image is about 50 x 20).


Image imports but much smaller than actual size. In fact, I can barely see it.


4. Click "Original Image Size" (not sure why I should have to click this. It should be default.


Image is correct size, but now image widget is 1000 x 1000 pixels so it fills up my entire screen. I guess that I could leave it that size, but it gets in the way of other widgets. Using the crop tool has the same result.


My goal is an image widget that is only a little bigger than the actual image, so it does not get in the way of the other images. I have not worked with software that has this behavior.

photo
1

Getting back to the original problem (Adding image to screen background), I am beginning to think the problem is with TIFF images. When I try to import other file formats, it seems to work fine. When I click the "Add Image" link, the file types listed at the bottom of the Open dialog (Mac) clearly mentions .tiff.


Not sure whether that is a Justinmind setting or just a Mac default. Are TIFF images supported by Justinmind?


As for the small image problem, I figured out how to create a screen capture in another file format, so see attached (the view is actual size). b89e9a7f04ca90641e8dc91f5f3bb5e4

photo
1

We will run some tests with .tiff images and we'll tell you if we found what's wrong with that type of images.

photo
1

What about the image resizing issue? Sorry, I probably should have created a separate issue, but I thought that they might be related. I was having this problem with GIF images.

photo
1

Sorry, I forgot you had this 'subtopic' here. Could you send the .gif to me please to have a try?

photo
1

We already resolved this via email. It was my fault. The image had a large transparent background and I did not realize it.

photo
1

It's great to know! (and a big relief for us)