justinmind-logo
 
Upvote 1

Freeze column in data list

Need Answer Ivan Kandi 15 months ago

Hi,


Let's say I have a table (datalist) that I put in a dynamic panel. This Table has 20 columns and I want to freeze the first two columns. Is there a way to do it?


Thanks

Replies (7)
photo
1

Hello, you can show only the number of columns you need from the creation screen of your data list by only selecting the fields you want to show.

If you want to show all your datamaster in a data list but filter the information it shows, here is a tutorial that can help you: https://www.justinmind.com/support/how-to-prototype-advanced-search

If you want to show only two columns and then by one action show other fields of your master data, you can use two tables or lists and with the element selected, from the properties palette use the eye icon to hide in simulation, then you will have to add the event "show hidden element" in a button or other element to show it.

let me know if this is what you needed.

Greetings.

photo
1

HI Ria, I wrote a respond but for some reasons it wasn't saved. If you got two responses, please disregard one of them.


And thank you for a very thorough respond as always. I apologize I wasn't clear.

I am trying to achieve a feature that is similar to the regular spreadsheet like a Good Spreadsheet.

Here's an example: Freeze column in google spreadsheet (please skip to 1:11).


What I've done:

1. I duplicate a table, so I have Table A and B. I place them both in a dynamic panel.

2. For Table A, I keep the first two columns and place it as a top layer

3. For Table B, I keep everything.

4. I pin Table A to its X axis to mimic the freeze feature.


This works, but every time I scroll, Table A shifts a bit before immediately pins itself back to the original location (readjusting itself). So it looks really funky. This method -otherwise- is fine, but any chance we can prevent Table A to shift at all?


Or if there is a better way to do this, I'm open as well.


Thanks Ria


Ivan

photo
1

Hi Ivan, sorry for the inconvenience, could you tell us which browser you are using to simulate?

I am attaching an example, you will see that the first list has a pin to the left, and the second list has no pin at all.

With the first list selected, from the properties palette you have to select the "show always on top in simulation" icon, which is on the top right.

Please let me know if this example is helpful, if you continue to have shift issues, please let me know.

Greetings.

photo
1

Hi Ria,

It is not an inconvenience at all, I'm thankful for the help!

It seems that you forgot to attach the file, but I will try to find the option you're talking about and see if that helps.

By the way I'm using Chrome to simulate.


Thanks Ria


Ivan

photo
1

Hello, apologies! the file is attached.

Regards.

photo
1

Hi Ria, thank you for the file.


I did the same thing. And I think it's probably caused by a large data that I use, which causes the component to play a catch up because the memory is being used to process a large amount of data (I'm talking about a 500 lines of transaction each with a 12 months data). This may cause the pin to not work properly.


Ivan

photo
1

Hello Ivan, could you send us your vp to review it?

Thank you.

Leave a Comment
 
Attach a file