justinmind-logo
 
Upvote 1

Vertical scrolling in simulation not working after updating to 9.7.2

Known Case Method 7 months ago

I am on MacOS Big Sur and recently updated to Justinmind 9.8.1 because it kept crashing when I launched the program.


Now that I updated, I can no longer scroll vertically in any of my prototypes when I simulate them, even though I've adjusted the page to be 1080x3080 (to accommodate vertical scrolling). I have content in the form of a footer banner that I need to see is rendering properly when the user scrolls all the way down, but right now the simulations lock the user to only scroll a few px up and down. And yes, I've checked to make sure vertical scrolling is unlocked.


The old prototypes I've already uploaded to the cloud service scroll fine, but all the files that I've created on my computer do not allow for vertical scrolling when I simulate them.

Replies (6)
photo
1

Hello, sorry for the inconvenience, we have found an error and it is because you have set the File -> Simulate -> Configuration: "Fit to screen size" option.

We are working on a solution for this week.

At the moment as a workaround, if you use the Custom option at 100%, the scroll should work.

Greetings.

photo
1

Hi Ria,


This still does not work. I've attached a sample project that replicates this issue, and a screenshot of my settings. I've followed your guidelines and the scrolling is still broken.


Could you give a sense of when the issue will be fixed?

photo
1

Hello, I'm sorry for the misunderstanding, in your case if all the content is pinned on the screen when simulating, the size of the area is not calculated correctly and then the scroll does not appear. we will be working to solve this problem for future updates. At the moment, as a workaround, you can put some element at the bottom of the Screen and make it not be seen in simulation, I am attaching an image.

Greetings.

photo
1

Ok, thank you. It looks like putting an element at the bottom of the screen (in this case, my footer) and making it have a 0% opacity border and unpinning it in X and Y works.

photo
1

Hi, when I try your solution, it works fine, but now the site doesn't render properly in my laptop's screen. The content is cut off at the sides. It renders fine on an external monitor. When I reset the simulation settings to "Fit to screen size", it fits correctly, but then I cannot scroll. This is the same when I upload the project to the cloud platform. So it seems like I can only choose scrolling or a webpage that fits, not both. If I want both, I'd have to use an external monitor. Is there any way you could advise?

photo
1

Hello, the solution to this problem was released today with the new update.

Let us know if we can help you with anything else.

Greetings.

Leave a Comment
 
Attach a file