When export to HTML, rich text formatting gets messed up sometimes

Rach Seng shared this problem 6 years ago
Solved

I'm using 4.5.0 on Mac OS Lion 10.7.2. I'm working in a file that I originally created in 4.4. I've been adding more screens and masters to it since then. I've been having a problem with HTML output (in both 4.5 and 4.4).


I use rich text fields. Inside rich text fields, I use a mix of formatting (e.g. some text is bold, some is gray, some is blue, some is underlined, some is different font sizes).


When I export to HTML, sometimes the formatting gets messed up, in the HTML files. For example, it will underline ALL the text, instead of just the words that I had underlined. So, it does not match how it looks inside Justinmind.


I think this happens when I use rich text fields in masters.


It looks like Justinmind is applying the formatting for the first character inside the field, to all of the text inside the rich text field, when I export to HTML.

Comments (4)

photo
1

Could you send an example .vp file to jim.support at justinmind.com please?


Thanks in advance

photo
1

A very simple test to prove that this is an issue:


1. Add a Rich Text component


2. Insert text so that it fills the full width


3. Run the simulation - it should display correctly


4. Export to HTML or Usernote - the text will be bigger, and will not fit in the box

photo
1

Sorry but we can't reproduce it. Could you send us an example please?

photo
1

To respond to the original post: this is no longer an issue in version 4.6, as far as I can tell. if I have rich text on the masters, the text formatting is now preserved when I export screens to HTML.


To respond to ba77ar's comment: The issue that you describe is actually a different issue. I describe that issue in this post: https://www.justinmind.com/community...