View on device doesn't update, shows old versions

Dylan Evans shared this problem 3 years ago
Solved

I updated the prototype with many changes, then pressed view on device, and an old version shows. I then save the prototype with a different name, and do the same again. It's now updated on the device. I make more changes. view on device pressed (and modal box gives the upload progress). Device version not updated. save as different filename, press view on device again. still not updated. do this many times, and it still doesn't update. Oh, if I press view on device and it starts the downloading prototype - if the iphone times out and then I unlock it afterwards it throws an error saying server couldn't connect. can't it d/l in background?


Help. I need to share this, and at the moment, I can't. I decided to use justinmind because it had an example for a slidier where the control stepped on each point (stepped slider). I've spent nearly 20 hours with justinmind - it's quirky, and has many weird little interface/ui issues which show one page selected but another page on the canvas. I'm using the latest on latest Mac yosemite.


Would I recommend it? no. but then again, there are still no prototyping tools I'd recommend to anyone after using them. Pixate doesn't really allow multiple screens, proto.io is ok (but I wanted to try justinmind for this project), Axure makes you think like a programmer which isn't great (very technical though powerful).


please give us a prototyping tool that works well.

Comments (1)

photo
1

Hi Dylan,


Please could you tell me which device are you using to view your prototype?


Also it will be useful to know which option are you using on the app to update the prototype.Did you use the "Refresh" button that appears on a top layer when you are viewing a prototype? Or did you go back to the prototype list and selected the "View on device" option on the bottom of the screen?