Simulate does not work for 5.0, with the iPhone example VP

Christopher Winter shared this question 6 years ago
Answered

Simulate does not work for 5.0, with the iPhone example VP. By not work, I mean, a blank page loads. This worked for me with the previous (4.6.1) version. I am using the Mac version. Please help.


thanks - chris

Comments (15)

photo
1

Have you ever installed a 5.0 beta version? If so please delete this folder: /your user/Justinmind/5.0 and launch Prototyper again.


If that’s not your case then it’s more complicated. The real thing is you can’t use Chrome to simulate your prototypes from Prototyper. But it should appear a message telling that, not a blank page. So the workaround is to go to Prototyper’s preferences and select ‘safari’ as the browser you want to use for your simulations.

photo
1

Hi Victor,


Thanks for the reply. I did figure out that Simulate works with Safari. Simulate did work with Chrome in the 4.6.1 version - has this broken with 5.0? Is there a timeline to get this working with Chrome?


I did not have a Beta version of 5.0.


thanks - chris

photo
1

Could you try something for me please? Could you go to Prototyper -> Preferences and select 'chrome' as the 'default browser' and try the simulation again?

photo
1

Hi Victor,


I tried it, and that works even less. After hitting Simulate, I switch over to Chrome but no page ever loads or tries to load (ie, the address bar never shows anything like /Justinmind/5.0.0/work0/894842960482872594/index.html#/screens/10d9c387-5fca-4102-a9e8-f6d733f693af).


When I do not specify Chrome, it does bring up a URL but simply loads a blank page.


thanks - chris

photo
1

Just to check, what happens if you choose another browser?

photo
1

I am having this same issue although I can't comment about anything before version 5.0. When chrome is selected within the preferences I get the same behavior. When Safari is selected as the default the simulation works properly.


Any idea when this will get integrated with chrome?

photo
1

Also, so that it's documented. Because I rarely use Safari on my Mac I never downloaded the flash plug-in for it. This was showing up in Justinmind as Blocked Plug-in when the error message maybe should have read missing plug-in.


Once I installed the flash plug-in for Safari it worked fine in the simulation although when viewing within Justinmind it still didn't work.

photo
1

We are fixing the Chrome thing for the next update. We will launch a patch in a couple of weeks or so. Thanks for your help.

photo
1

Hi there,


I'm using the Mac version4.6.2 and my OS is Mountain Lion. My default for opening HTML files is Sublime text editor, but i want to change that in Prototyper in order to Simulate prototypes in Chrome. But i'm not seeing that in the Preferences. I see it in the Windows version, where I had the same need, but not in the Mac. Can you tell me how to change the default browser?


60e740ef73fde788750e620894f274d2

photo
1

What version of Justinmind Prototyper are you using?

photo
1

I'm using Mac version 4.6.2.

photo
1

That option was included in version 5.0. You can download the latest version from our website.

photo
1

Trial Pro Edition, v.6.0.0


on OSX 10.9.4


Having similar problem, simulate doesn't refresh to reflect changes made (and saved). Tried Safari and Chrome (after installing the extension), both same problem.

photo
1

What kind of changes are not reflected on the simulation?

photo
1

Layout. I'm only playing with very basic stuff: adding, deleting, moving around the controls, mostly text and images. Every time I changed something, I saved and did a preview/simulate. Simulate would show some older layout from a previous save instead of the latest one. ie. it saved once and ignore any subsequent saves.