set value for image on mouse hover or click not working

CS shared this problem 6 years ago
Solved

I'd love to really be able to use your product, but I'm at the point of giving up due to defects in your programming. When attempting to use Set Value on an image widget, to change the image to a different image on mouse click or hover, when published to Usernote or exported to HTML, your source html code is referencing a link to the local filename from the C: drive of the computer where the image was selected in the Set Value interface.


Here's an example:


but should instead use src image refs to the proto html images location like below:


The latter works, the former does not an I would think for obvious reasons. Please don't tell me I'm using the tool wrong, because this is a defect. Can you get me a fix?

Comments (5)

photo
1

Here's an example:


<img id="s-Image_12" class="image firer click mouseenter mouseleave pageload ie-background commentable" alt="image" src="images/C:UsersLucasProjectsIconsinbox_active.jpg" style="display: block; ">


but should instead use src image refs to the proto html images location like below:


<img id="s-Image_9" class="image firer click pageload ie-background commentable" alt="image" src="images/88-%20tag%205.png" style="display: none; ">

photo
1

Hi,


The bug has been reported to the development team. We will try to fix it for the next update.


Regards

photo
1

When is the next update? I'm sure I can't be the only person who has experienced this problem, since it appears other users have reported the same behavior over 11 months ago in articles throughout your support site. Can't you provide me a workaround?

photo
1

You can use a dynamic panel with two panels, then place the first image in the first panel, the second image in the second panel and use the 'show' action to show one panel or another.

photo
1

Solved in Prototyper 4.6 release