Select List tied to a Data Master - only want *one* field to display in the dropdown, not all of them.

jjsararas shared this question 4 years ago
Answered

I've tied a Data Master to a Select List, but I don't want ALL the fields to appear in the dropdown inline separated by commas (the default). I only want to show one description field. How can I control this? Thanks!

Comments (2)

photo
1

Hi,


you have to use a set value action with this calculator operation:


313d04fe86b9b37ef71e88ecf6907ffc

photo
1

Sorry I'm not able to follow you.


I linked the dropdown to the Data Master, and now it's options in the sim look like:


Field1,Field2,Field3,Field4 (for (Item 1)


Field1,Field2,Field3,Field4 (for (Item 2)


Field1,Field2,Field3,Field4 (for (Item 3) and so on. All linked together by comma, no spaces or formatting.


I'd like to include/exclude some of the fields (e.g the keys) and also add formatting like:


Field2 - Field3, Field4 (replace comma with dash, add a space between the values etc)


I'm not sure how to concatenate these fields using the Set Value action as you suggested. Would you mind giving a little more detail. Much appreciated!