Menu submenus and navigation tree not working properly in generated HMTL version

vis shared this problem 7 years ago
Solved

Menu submenus and navigation tree nodes aren't working properly in the generated HTML version. I want to use menu submenus to have a functionality that clicking on the submenu changes the page. The tree nodes I want to have a functionality that clicking on the node a hidden dynamic panel is shown. Both of these functionalities work fine when I simulate the prototype in the Justinmind Prototyper but neither of these work in the generated HTML version. Clicking menu submenu doesn't do anything and clicking on the tree node just expands or collapses the tree but doen nothing else.

Comments (6)

photo
1

I'm afraid you have stumbled upon a bug, which made its way into this release. It's actually already fixed (but only available with the next update). We could export your prototype into HTML for you. Thank you.

photo
1

Thank you for the quick response. Good to know that there is fix coming with the next release and a way to generate working HTML version even before that. I will contact you if I need the HTML version generated. Can you give any estimate when the fixed version of the prototyper will be released?

photo
1

We are working in improving the performance but we believe we will have the next update available the beginning of the next week.

photo
1

Any update on when you will release the fixed version? The beginning of next week was a week ago:)

photo
1

There are two other small problems with menus in the HTML version:


a) text is always aligned to the right (you can have it aligned to the left or to the center only in the "Design" and "Simulate" modes)


b) if you turn off comments in order to have the prototype working under Chrome, the menu does not expand at all, ie. submenus are not visible

photo
1

Solved in 4.1.1 now available in our website. Fix is being prepared for Usernote.