invalid configuration location

Samantha shared this problem 6 years ago
Solved

I am getting the following error when I try to open JIM


'Invalid Configuration Location - The configuration area at '/Users/samanthag/Justinmind/4.40/configuration' could not be created. - Please choose a writable location using the '- configuration' command line option.'


I am not how to use the command line option ... please help.


I am running Mac OS X Version 10.7.2 ... this includes the latest mac updates.

Comments (20)

photo
1

Could you describe the installations and updates you made until that error happened? The folder which is referred in the error message is really weird. It should be '/Users/samanthag/Justinmind/4.4.0 instead of '/Users/samanthag/Justinmind/4.40 for some reason a dot has been missed.

photo
1

Hi,


We recently installed this in our labs as well and we get this message as well. I think its trying to write something in an admin location and we are using a local account. How can we set to configuration to use a local folder.


Thanks


Manoj

photo
1

Did you install the software with an Admin and then launch it with a normal user or did you launch it with the user Admin the first time?

photo
1

I installed it and launched at as a user, If I remember right I also did the other way.

photo
1

same exact problem here - I am installing on a windows 7 vm running inside osx lion. I have tried installing as administrator and running under local account and installing as an administrator and running as an admin - both result in the same error "...vmware-hostshared foldersjustinmind4.4.1configuration could not be created. Please choose a writable location via the -configuration command line option"

photo
1

Could you check if the folder vmware-hostshared foldersjustinmind4.4.1 exists please?

photo
1

got it working, I just modified the Justinmind prototyper config file. and removed the @user.home.

photo
1

have you tried to save a project that contains images, and then reloading that file? I end up with what appears to be broken paths to all images ("red X boxes"), everywhere an image had been.

photo
1

it does not

photo
1

It looks like the path is wrong some way (just an off topic, Justinmind is not intended to be used on virtualized computers). The good one should be vmware-hostshared foldersjustinmind4.4.1 . Open the file named JustinmindPrototyper.ini which is next to the .exe in the Justinmind's installation folder. Change the path @user.home... by the correct path and check it again please.

photo
1

I've just had the same issue. Does anyone know how to fix it?

photo
1

Which version of Prototyper are you using?

photo
1

I'm having this problem too on a mac 10.6.8 (installing 10.8 now to see if it's working with that).


The text:


The configuration area at '/Users/myusername/Justinmind/5.1.10/configuration' could not be created. Please choose a writable location using the '-configuration' command line option.


I have no clue how to do that. Do you do it through terminal, or...?

photo
1

You have to cmd+click on Prototyper Pro application and select 'Show package contents' Then open this folder: /Contents/MacOS/ and there edit the Prototyper Pro.ini file. Remove everything that is below @configuration (that line included) and run Prototyper again.

photo
1

Ok. This is what I get when I open Prototyper Pro.ini:


Last login: Wed Mar 13 13:28:39 on console


Myuser-MacBook-Pro:~ Myuser$ /Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini ; exit;


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 1: -configuration: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 2: @user.home/Justinmind/5.1.0/configuration: No such file or directory


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 3: -data: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 4: @user.home/Justinmind/5.1.0: No such file or directory


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 5: -vmargs: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 6: -Xms256m: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 7: -Xmx512m: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 8: -Xss512k: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 9: -XX:MaxPermSize=256m: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 10: -Dorg.eclipse.swt.internal.carbon.smallFonts: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 11: -Dfile.encoding=UTF-8: command not found


/Applications/Prototyper Pro.app/Contents/MacOS/Prototyper Pro.ini: line 12: -Dsun.jnu.encoding=UTF-8: command not found


logout


[Prosess utført]


Is this how it should be?

photo
1

Sorry, I should have been more clear. You have to open Prototyper Pro.ini with a text editor.

photo
1

Ok, got it. Thanks!

photo
1

I'm confused: How can this be labeled "Solved?" I don't see a solution other than going in by hand and messing around with some Windows config files or something. I've worked in the software industry for many years and this is unacceptable -- installation should be straightforward and trouble-free. This is not a good out-of-the-box user experience.


I saw the comment that Justinmind was not meant to be installed on a vm. This makes no sense to me. The installer should see Windows 7 as an actual OS and install accordingly.


I was evaluating this as an alternative to Axure. Guess I stick with Axure for now.

photo
1

I got the same problem. I'm using OS X 10.6.8.


In text editor it says:


-configuration


@user.home/Justinmind/5.6.0/configuration


-data


@user.home/Justinmind/5.6.0


-vmargs


-Xms256m


-Xmx512m


-Xss2m


-XX:MaxPermSize=256m


-Dfile.encoding=UTF-8


-Dsun.jnu.encoding=UTF-8


-Dorg.eclipse.swt.internal.carbon.smallFonts


-Djavax.xml.parsers.SAXParserFactory=com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl


-Djavax.accessibility.assistive_technologies=


Which lines do I have to clear?


And then I can't save this file again.


Any other solutions?

photo
1

Hi Tina,


Create a new file with a text editor and paste the following code:


-vmargs


-Xms256m


-Xmx512m


-Xss2m


-XX:MaxPermSize=256m


-Dfile.encoding=UTF-8


-Dsun.jnu.encoding=UTF-8


-Dorg.eclipse.swt.internal.carbon.smallFonts


-Djavax.xml.parsers.SAXParserFactory=com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl


-Djavax.accessibility.assistive_technologies=


Then, save it as "PrototyperPro.ini".


Now, what you have to do is cmd+click on Prototyper Pro application and select 'Show package contents' Then open this folder: /Contents/MacOS/ and there replace the Prototyper Pro.ini file for the new one that you have created.