I love the product, but...

Dee Skiver shared this thanks 2 years ago

I love the product, but the support is severely lacking. Both from the community and the employees. It takes WAY to long to get responses on issues.

Comments (8)

photo
1

Yes, this is very disappointing.

photo
1

:(


Their response speed is particularly slow, and usually they don't give clear answer.

photo
1

Hi Dee / Liangwang ,


We are sorry to hear that our support community doesn't cover your expectations as we're always aiming to provide the best experience and solutions for all users.


Please be advised that in case you are using a license, the customer support portal is available and will be able to give you a quicker response.


Best,


Sonia Durán

photo
1

Hi Liangwang,


In case you don't understand any of our responses please do not hesitate to let us know.


Best,


Sonia Durán

photo
1

I agree the support is severely lacking including in the customer support portal. I have been a long-time fan of Justinmind and have had my teams buy licenses for it in several companies over the years. Between the lacking support and the recent problem of published prototype linked pages loading extremely slowly (2 to 3 seconds), it's becoming increasingly difficult to justify using it since it's not at all usable for usability testing. I submitted a ticket for that problem in the customer portal 3 days ago. Somebody got back to me that day asking for example links and vp files. I sent the examples and haven't heard back since. I love the product and hope the support gets better soon.

photo
1

Hi Kit,


I'm sorry to hear that your ticket haven't been answered as all of the inquiries through our customer support portal have usually a quick reply.


If possible, please list the ticket number so I can investigate what may have happened and be able to provide you an answer to your inquiry as soon as possible. Sorry for any inconvenience.


Best,


Sonia Durán

photo
1

Hi Sonia,


Sometimes it takes a couple days to hear back and even longer for the problem to be resolved. I have two problems that are unresolved.


The first one is Request #15782. The problem is still unresolved because when a prototype is not set to public, it takes several seconds to load a page when a user clicks a link. The representative did get back and said a problem had been found with your servers, but I haven't had an update for six days!


The other problem is Request #15791. The IT department here got a Justinmind enterprise account for several people on my team, but they are unable to log into the Customer Support Portal. The representative said Justinmind accounts and Customer Support Portal accounts are separate. I don't understand what that means or how my team can get the support they need for themselves.


Your assistance would be most appreciated!


Thanks,


Kit

photo
1

Hi Kit,


We're sorry that we haven't been as quick to respond on this issue - it is quite complex. Hopefully we'll have a resolution soon.


Thank you for your patience so far.


Best,


Danielle