Data Grid: displays three rows when Rows per Page are set to 0.

Derek Fricano shared this problem 6 years ago
Not a Problem

The title kind of says it all, I guess: when I add my data grid, I want it to default to 0 visible rows. With the properties set as such, my generated prototype always shows 3 rows. If I set the property to any value other than 0, it displays the correct number of rows... but 0 appears broken. Any tips/tricks/fixes?

Comments (5)

photo
1

0 means 'no restriction' so it shows all the elements in the data master. If you want to show an empty data grid add an event on page load -> set value -> data grid -> value is -> (leave it blank)

photo
1

Thanks, Victor. In doing that, it's broken some functionality of my prototype: after adding the on page load event, I am unable to add rows to the data grid. Any ideas on a fix?


Just my opinion, but "0 = no restriction" makes sense to me. I think actually having a "no restriction" option in the properties may be a more usable solution while making "0" actually represent "0 rows".

photo
1

How are you adding more rows to the data grid?

photo
1

Using the "New_____" maintenance screen that is generated when I created the data master.

photo
1

I think this video can help you with that:


http://www.justinmind.com/prototyper/...