Cursor gets stuck on drag action when switching screens

Mark DeHate shared this problem 5 years ago
Solved

Okay, this is a weird issue, but I'll describe it the best that I can. I've found that occasionally, when clicking on a screen in the Screens panel to switch to, the cursor will get stuck on the drag screen action. So the cursor turns into the grabbing hand icon as if I was trying to make a link to that screen.


So again... I'm using the Screens panel to switch screens. I click (once) on a screen, and instead of just switching to that screen, it switches to the screen and turns the cursor to the grab hand like I'm going to make a link. It's like Prototyper thinks I did a click and a half, when I only clicked.


I've done this with both a USB mouse and my laptop's trackpad, so it's definitely not my hardware.


Unfortunately (I guess) it's not a consistent thing. It seems to happen more frequently if I have an object selected on the current page; I'd say it happens about 75% of the time in this circumstance. But sometimes it happens with nothing selected, and sometimes it works fine.


I've tried it with big files (many many screens) and brand new files (with only one rectangle on each screen) - it happens as frequently on both.


It seems like a small thing, but it's actually quite irritating. More than once, I haven't noticed what's going on and I accidentally make some random element on my page link to a new screen (that was fun to debug). Is this a known issue? It would be awesome if it could get fixed....


(update: I'm using the Mac version of Prototyper, version 5.1)

Comments (7)

photo
1

We'll look into it.

photo
1

Have you been able to duplicate this issue? I'm still seeing the behavior, and I'm discovering it's in a lot of places.


For example...if I have Google Chrome active, and I click into the Prototyper canvas area somewhere, it will start a drag select action. So I click into the Prototyper window, and move my mouse, and I get the marching ants rectangle. This happens every time that I try.


When just clicking on the tabs in the floating palettes, that frequently "sticks" a drag action, which means about 50% of the time I end up separating one of those tabs into its own window.

photo
1

I have the same issue on my MacBook Pro and some more. All bugs involves clicking. It gets stucked as drag even if I do a simple click. Sometimes a click into Properties Palette turns into dragging the palette. I have to doble click on the canvas to release the palette, next click it's an error and the next thing i have to put the palette at it's place. It's frustrating: this kills time!


For some buttons in palettes, I have to click twice: first it focuses the button and at the second one it activates it! It's weird.


Right-click it's lazy to show up. i have to do 3-4 intents clicking some other objects in-between.


As Marks says: 50% of the clicks on a mac are errors! And this is in paid version.

photo
1

Mark,


We have reproduced the two problems you mentioned. You are working with floating canvas instead of docked. When docked, none of this is happening (at least to us!),


but when is floating, there is some behavior in Mac done to maintain focus wherever you click.


We need time to debug what really is causing this issue, so this won’t be fixed for the 5.6 update. You can dock your floating palettes or wait a little longer for the fix.

photo
1

Hi John, thanks for the reply. You're right - if I dock those windows it works a lot better. I still get the click-and-drag behavior when clicking in the canvas from another application, but that's way easier to deal with.


Thanks for the tip!

photo
1

We get this problem consistently. It gets more frustrating when we're busy and need to switch between windows. 3 years is a long time for sometime like this to remain open.


Is there an end in sight?

photo
1

found a fix for this problem, just add a hotspot on top of the dragable item and add a drag function to the hotspot, to trigger the dynamic panel


Also make sure for the hotspot always on top is checked , the issue is when you apply dragging the draggable item moves on the top layer so everything else moves below that layer